[zb4osgi Dev] to display zigbee devices information.

Manlio Bacco manlio.bacco at isti.cnr.it
Mon Mar 11 23:51:35 CET 2013


Hi Manel,

please write to ZB4O mailing list to receive support. Your doubts and 
relative solutions (if any) may be useful to all developers/users of the 
project.

Now the tester cannot display topology information, but, as far as I 
remember, there is a service that can help you obtaining it. I will try 
to be more precise tomorrow, sorry, I cannot access to source code in 
this moment.

The statement you indicate in log traces is strange, could you please 
attach the log to allow analysis? Anyway, a possible reason is that you 
can read the mentioned statement because the device does not respond in 
a particular moment (maybe it's sleeping), while when it joins the 
network the announce is correct and the endpoint(s) inspection is 
successfully because it's not sleeping.

BR,
Manlio

Il 3/7/2013 2:17 PM, manel manel ha scritto:
> Hello,
> Could you, please, help me , i'm using the Zb4osgi code but i didn't
> findhow can display some zigbee network properties
> ..
> Actually , i'm using the tester bundle to display zigbee devices but with
> the tester i can't see topology information (father, child , neighbours ..)
> and properties like depth, rxlqi..
> I think that all properties are inherited from HADevice and CC2530driver
> but not from ZigBee Node and ZigBee Network..
>
> Have you an idea about this service,and could you please help me ?
>
> in log traces i see
> "it.cnr.isti.zigbee.basedriver.discovery.NetworkBrowserThread - Found 0
> neighbors on node 0 " and with the tester i can see my binary light device.
> Are there something missing for me ?
>
>
> Thank you in advance,
> Bets Regards,
> Manel.
>




More information about the Dev mailing list