[zb4osgi Dev] Problem building, nexus.aaloa.org down?

Ryan Press ryan at presslab.us
Mon Dec 8 18:17:00 CET 2014


Thanks Han,

I would like the f8wConfig.cfg for the coordinator, do you have one of
those?

I buy the bulbs locally at Home Depot.  I think they ship international.
There is also Amazon and eBay.  But will these bulbs work for you?  I think
they will screw in, but I'm not sure they can do 230V as we have only 120V
here.  But there is a chance they will work because of the switching power
supply.

Thanks again,
Ryan
On Dec 8, 2014 8:22 AM, "Han Alink" <h.alink1 at chello.nl> wrote:

>  Hi Ryan,
>
>
>
> The f8wConfig.cfg files are not the same for every module.
>
> Here is one for sleeping end-devices (see also
> http://zigbeedomotica.nl/multi-function-input-device/) and one for end-
> device/routers.
>
> I use a fixed channel and a fixed PanId at the moment. PanId = 0x0004 for
> my operational system and 0x0005 for test purposes. I use z-stack Home 1.2.
>
> Where should I buy those bulbs (shipment to Holland)?
>
> Regards,
>
> Han
>
>
>
>
>
> *From:* Dev [mailto:dev-bounces at zb4osgi.aaloa.org] *On Behalf Of *Ryan
> Press
> *Sent:* maandag 8 december 2014 16:28
> *To:* ZigBee for OSGi help and dev
> *Subject:* Re: [zb4osgi Dev] Problem building, nexus.aaloa.org down?
>
>
>
> Hi Han,
>
> Yes, I can fully control the GE link bulb with ZB4O.  On/off and dimming
> work as expected.  It's even possible to control the dimming speed.
>
> I will update the Google Docs spreadsheet when I have time.
>
> It is your HEX file that I was able to use, could you share your working
> f8wConfig.cfg?
>
> Thanks,
> Ryan
>
> On Dec 8, 2014 4:09 AM, "Han Alink" <h.alink1 at chello.nl> wrote:
>
> Hello Ryan,
>
> Are you able to control the GE link light bulbs from ZB4O?
> If you are or when you are, I would like to know.
>
> Best regards,
> Han Alink
>
> -----Original Message-----
> From: Dev [mailto:dev-bounces at zb4osgi.aaloa.org] On Behalf Of Ryan Press
> Sent: vrijdag 5 december 2014 19:12
> To: ZigBee for OSGi help and dev
> Cc: fabio.mavilia at isti.cnt.it
> Subject: Re: [zb4osgi Dev] Problem building, nexus.aaloa.org down?
>
> Hi Stefano,
>
> I did install Pax-Runner-UI from UniversAAL but I am having some
> difficulty.  Maybe I will figure it out soon.
>
> I have the 60W GE Link bulb, it is working fine.  This is very
> inexpensive here, only $15 USD, and available at the local hardware
> store.
> http://gelinkbulbs.com/
>
> I also have the two Centralite 3-Series modules, this:
> http://www.centralite.com/index.php/products/3-series/3-series-lamp-module/
> And this:
>
> http://www.centralite.com/index.php/products/3-series/3-series-appliance-module/
>
> They are a bit newer than the one I linked before.  Most things are
> working, but they have the ability to report power consumption which
> I'm most interested in.  Specifically they show clusters 0x0B04 and
> 0x0B05.
> I am not sure the format of these clusters, I have found two
> descriptions for 0x0B04.  Note these documents are "proposed" and not
> ratified.
>
> http://www.energy-home.it/Documents/Technical%20Specifications/E@h_specification_ver2.0.pdf
>
> http://www.docstoc.com/docs/147321957/docs-11-5734-20-00ha-electrical-measurement-cluster-draft-spec
>
> Maybe it is the E at h specification that these newer ones work with.
>
>
> Thanks,
> Ryan
>
>
> On Fri, Dec 5, 2014 at 7:24 AM, Stefano 'Kismet' Lenzi
> <kismet.sl at gmail.com> wrote:
> > HI Ryan,
> >
> > I think that Fabio can help you with the issue reported in
> > http://zb4osgi.aaloa.org/pipermail/dev/2014-November/001061.html
> >
> > Running within Eclipse is kind of complex because you need the
> Pax-Runner-UI
> > from OPS4J which as far as I know is not supported nor developed
> anymore, so
> > I recommend using remote debugging for testing the environment or you may
> > try to define an execution environment with Eclipse PDE or with OSGi
> EnRoute
> > (but you will be on an unknown field, so any tutorial after your
> experience
> > would be welcomed -_^ )
> >
> > If you are going to extend ZB4O with new Cluster we will appreciate it as
> > contribution, do not hesitate to ask for help :)  It means also that you
> are
> > using http://www.centralite.com/ devices, am I right? Which devices
> have you
> > tested so far?
> >
> > According to the documentation
> > (
> http://centralite.readthedocs.org/en/latest/devices/lights/usdimmer.html)
> > it seems to me that the "Electrical Measurement" cluster is a Vendor
> > specific cluster that does not belong to any ZigBee published standard
> (as
> > far as could look on the ZigBee specification), can you correct me on
> this?
> >
> > Ciao,
> > Stefano
> >
> > On Thu, Dec 4, 2014 at 8:19 PM, Ryan Press <ryan at presslab.us> wrote:
> >>
> >> Hi Stefano,
> >>
> >> Yes, thanks, I saw your other answer, and replied to it:
> >>
> >> http://zb4osgi.aaloa.org/pipermail/dev/2014-November/001061.html
> >>
> >> I know the server was down maybe some mail was lost.  Thanks again, if
> >> you have some information on the firmware that would be nice.
> >>
> >> Also I want to try it in Eclipse.  I see there are some launch files
> >> under zigbee.ha.driver.
> >>
> >> I am now going to try implementing "Electrical Measurement" cluster.
> >> Here is (almost) my device:
> >>
> http://centralite.readthedocs.org/en/latest/devices/lights/usdimmer.html
> >>  It should be straightforward to do this, I think.
> >>
> >> Thanks,
> >> Ryan
> >>
> >>
> >> On Tue, Dec 2, 2014 at 9:23 AM, Stefano Lenzi <
> stefano.lenzi at isti.cnr.it>
> >> wrote:
> >> > Hi Ryan,
> >> >
> >> > I thought that I answered to you, but considering that I was writing
> >> > with my
> >> > mobile something has gone wrong and my e-mail never reached you...
> >> > Please look at my commet inline
> >> >
> >> > Ciao,
> >> > Stefano
> >> >
> >> > Il 26/11/2014 17:26, Ryan Press ha scritto:
> >> >>
> >> >> Hi Francesco,
> >> >>
> >> >> Yes, it gets further now, thanks!  But I see this error when it runs
> >> >> the
> >> >> tests:
> >> >>
> >> >> Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.021
> >> >> sec <<< FAILURE! - in
> >> >> it.cnr.isti.zigbee.basedriver.communication.AFLayerTest
> >> >>
> >> >>
> >> >>
> getSendingEndpointZigBeeDeviceCluster(it.cnr.isti.zigbee.basedriver.communication.AFLayerTest)
> >> >>   Time elapsed: 0.021 sec  <<< FAILURE!
> >> >> java.lang.AssertionError:
> >> >>    Unexpected method call getProperty("it.cnr.isti.zigbee.pan.id"):
> >> >>      at
> >> >>
> >> >>
> org.easymock.internal.MockInvocationHandler.invoke(MockInvocationHandler.java:45)
> >> >>      at
> >> >>
> >> >>
> org.easymock.internal.ObjectMethodsFilter.invoke(ObjectMethodsFilter.java:73)
> >> >>      at com.sun.proxy.$Proxy5.getProperty(Unknown Source)
> >> >>      at
> >> >> it.cnr.isti.osgi.util.OSGiProperties.getInt(OSGiProperties.java:131)
> >> >>      at
> >> >>
> >> >>
> it.cnr.isti.zigbee.basedriver.configuration.ConfigurationService.<init>(ConfigurationService.java:66)
> >> >>      at
> >> >>
> >> >>
> it.cnr.isti.zigbee.basedriver.api.test.ZigBeeBaseDriverTestUnitBase.<init>(ZigBeeBaseDriverTestUnitBase.java:75)
> >> >>      at
> >> >>
> >> >>
> it.cnr.isti.zigbee.basedriver.communication.AFLayerTest.<init>(AFLayerTest.java:67)
> >> >>
> >> >> Anyone have an idea with this one?
> >> >
> >> >
> >> > I have to look as such Test Failure, but the best way for you is to
> >> > build by
> >> > skipping the test. Maven allows you to skip tests by addin -DskipTests
> >> > as
> >> > parameter, thus you have to execute the command
> >> > mvn -DskipTests install
> >> > instead of
> >> > mvn install
> >> >
> >> >
> >> >
> >> >>
> >> >> Thanks again,
> >> >> Ryan
> >> >>
> >> >>
> >> >>
> >> >> On Wed, Nov 26, 2014 at 7:36 AM, Francesco Potortì
> >> >> <Potorti at isti.cnr.it>
> >> >> wrote:
> >> >>>>
> >> >>>> I'm trying to build zb4osgi, but for the past few days I get Error
> >> >>>> 503
> >> >>>> when trying to access http://nexus.aaloa.org.  Is this server
> down?
> >> >>>
> >> >>> It should be fixed now.  Can you try again?
> >> >>>
> >> >>> --
> >> >>> Francesco Potortì (ricercatore)        Voice:  +39.050.621.3058
> >> >>> ISTI - Area della ricerca CNR          Mobile: +39.348.8283.107
> >> >>> via G. Moruzzi 1, I-56124 Pisa         Skype:  wnlabisti
> >> >>> (entrance 20, 1st floor, room C71)     Web:
> http://fly.isti.cnr.it
> >> >>>
> >> >>> _______________________________________________
> >> >>> Dev mailing list
> >> >>> Dev at zb4osgi.aaloa.org
> >> >>> http://zb4osgi.aaloa.org/mailman/listinfo/dev
> >> >>
> >> >> _______________________________________________
> >> >> Dev mailing list
> >> >> Dev at zb4osgi.aaloa.org
> >> >> http://zb4osgi.aaloa.org/mailman/listinfo/dev
> >> >
> >> >
> >> >
> >> > --
> >> > Dr. Stefano Lenzi
> >> > OSGi Invited Researcher
> >> > Tel: +39 050 621 2844
> >> > Fax: +39 050 315 2811
> >> > Skype: kismet-sl
> >> > Istituto di Scienza e Tecnologie dell’Informazione “A. Faedo”
> >> > Consiglio Nazionale delle Ricerche
> >> > Via Moruzzi, 1, 56124 - Pisa - Italy - Stanza C66
> >> >
> >> >
> >> > _______________________________________________
> >> > Dev mailing list
> >> > Dev at zb4osgi.aaloa.org
> >> > http://zb4osgi.aaloa.org/mailman/listinfo/dev
> >> >
> >>
> >> _______________________________________________
> >> Dev mailing list
> >> Dev at zb4osgi.aaloa.org
> >> http://zb4osgi.aaloa.org/mailman/listinfo/dev
> >
> >
> >
> > _______________________________________________
> > Dev mailing list
> > Dev at zb4osgi.aaloa.org
> > http://zb4osgi.aaloa.org/mailman/listinfo/dev
> >
>
> _______________________________________________
> Dev mailing list
> Dev at zb4osgi.aaloa.org
> http://zb4osgi.aaloa.org/mailman/listinfo/dev
>
>
> ---
> Dit e-mailbericht is gecontroleerd op virussen met Avast antivirussoftware.
> http://www.avast.com
>
>
> _______________________________________________
> Dev mailing list
> Dev at zb4osgi.aaloa.org
> http://zb4osgi.aaloa.org/mailman/listinfo/dev
>
>
> ------------------------------
>    <http://www.avast.com/>
>
> Dit e-mailbericht is gecontroleerd op virussen met Avast
> antivirussoftware.
> www.avast.com
>
>
> _______________________________________________
> Dev mailing list
> Dev at zb4osgi.aaloa.org
> http://zb4osgi.aaloa.org/mailman/listinfo/dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://zb4osgi.aaloa.org/pipermail/dev/attachments/20141208/b1f9ab30/attachment-0001.html>


More information about the Dev mailing list