Bug #128

IdentifyTime attribute

Added by Han Alink over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:10/17/2012
Priority:Normal Due date:
Assignee:Stefano Lenzi % Done:

100%

Category:zigbee.tester Spent time: -
Target version:org.aaloa.zb4osgi.zigbee.tester-1.X
Has a patch:No Has license agreement signed:No

Description

Writing to the IdentifyTime attribute fails when the input field is empty (number format exception).

Associated revisions

Revision 518
Added by Stefano Lenzi over 5 years ago

Report invalid value instead of NumberFormatException when setting a numeric attribute if the data does not represent a number ( fixes #128 )

Default values for Subscribing are taken from the zigbee.zcl.library bundle

History

#1 Updated by Stefano Lenzi over 5 years ago

  • Status changed from New to In Progress
  • Assignee changed from Francesco Furfari to Stefano Lenzi
  • Target version set to org.aaloa.zb4osgi.zigbee.tester-1.X

The issue is a generic issue related to all the writeable attribute, but on the contrary of the Subscription issue (#126) I believe that we should notify the user that a value is need instead of using a default value

#2 Updated by Stefano Lenzi over 5 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Applied in changeset r518.

Also available in: Atom PDF