Bug #133

Missing Parameters Group commands

Added by Han Alink over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:10/18/2012
Priority:Low Due date:
Assignee:Stefano Lenzi % Done:

0%

Category:zigbee.zcl.library Spent time: -
Target version:org.aaloa.zb4osgi.zigbee.zcl.library-1.X
Has a patch:No Has license agreement signed:No

Description

The "AddGroup" and "ViewGroup" commands are missing the "GroupName" parameter in the tester interface.
See also "addGroupIfIdentifying" which has both the Id and the name as input.

Associated revisions

Revision 532
Added by Stefano Lenzi over 5 years ago

Added parameter GroupName to the AddGroup command of the Groups cluster ( refs #133 )
Updated Scenes interface and implementaion in ZigBee Home Automation Driver to reflect the updated of ZigBee Cluster Library ( refs #135 )

Revision 621
Added by Stefano Lenzi about 5 years ago

Reapplying fix that was deleted due to the merge ( refs #152 ) ( refs #174 )
Added JUnit for regression test ( refs #152 ) ( refs #133 )

History

#1 Updated by Stefano Lenzi over 5 years ago

  • Category changed from zigbee.tester to zigbee.zcl.library
  • Assignee changed from Francesco Furfari to Manlio Bacco
  • Target version set to org.aaloa.zb4osgi.zigbee.zcl.library-1.X

#2 Updated by Stefano Lenzi over 5 years ago

  • Status changed from New to Feedback
  • Assignee changed from Manlio Bacco to Stefano Lenzi

GroupName to AddGroup has been added, but ViewGroup doesn't seem to have a GroupName paramter, am I right?
Please let us know and close the ticket if it works for you

#3 Updated by Han Alink over 5 years ago

According to the ZCL spec, the View Group command should be sent with the GroupID as parameter.
The name of the Group will be returned.
See 3.6.2.2.4 View Group Command

#4 Updated by Stefano Lenzi over 5 years ago

Dear Han,
I'm missing something, by looking to the latest ZCL Specifaction (updated to May'12) available from ZigBee Alliance the View Group Command (see 3.6.2.3.2 on page 134) has only the GroupId as payload ( see Figure 3.10 ). The answer to View Group Command should be a View Group Response Command ( see 3.6.2.4.2 ) and it should contains Status, GroupId, and GroupName which are correctly defined in the ViewGroupResponse

What am I missing?

#5 Updated by Han Alink over 5 years ago

  • Status changed from Feedback to Closed

You are missing nothing; I was missing the latest release of the document. Sorry ...
Assuming that the GroupName and AddGroup have been added, I am closing the item

Also available in: Atom PDF