Bug #143

compilation error

Added by Han Alink about 6 years ago. Updated about 6 years ago.

Status:Closed Start date:10/21/2012
Priority:Lowest Due date:
Assignee:Stefano Lenzi % Done:

0%

Category:zigbee.zcl.library Spent time: -
Target version:org.aaloa.zb4osgi.zigbee.zcl.library-0.8.0
Has a patch:No Has license agreement signed:No

Description

Trying to install the latest revision (532) leads to a compilation error:

[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] \ZB4Osgi\trunk\zigbee.ha.driver\src\main\java\it\cnr\isti\zigbee\ha\clus
ter\glue\general\Scenes.java:[31,56] cannot find symbol
symbol : class RemoveAllScenesResponse
location: package it.cnr.isti.zigbee.zcl.library.api.general.scenes
[ERROR] \ZB4Osgi\trunk\zigbee.ha.driver\src\main\java\it\cnr\isti\zigbee\ha\clus
ter\glue\general\Scenes.java:[50,8] cannot find symbol
symbol : class RemoveAllScenesResponse
location: interface it.cnr.isti.zigbee.ha.cluster.glue.general.Scenes
[ERROR] \ZB4Osgi\trunk\zigbee.ha.driver\src\main\java\it\cnr\isti\zigbee\ha\clus
ter\impl\ScenesImpl.java:[34,56] cannot find symbol
symbol : class RemoveAllScenesResponse
location: package it.cnr.isti.zigbee.zcl.library.api.general.scenes
[ERROR] \ZB4Osgi\trunk\zigbee.ha.driver\src\main\java\it\cnr\isti\zigbee\ha\clus
ter\impl\ScenesImpl.java:[119,8] cannot find symbol
symbol : class RemoveAllScenesResponse
location: class it.cnr.isti.zigbee.ha.cluster.impl.ScenesImpl
[ERROR] \ZB4Osgi\trunk\zigbee.ha.driver\src\main\java\it\cnr\isti\zigbee\ha\clus
ter\impl\GroupsImpl.java:[59,61] addGroup(int) in it.cnr.isti.zigbee.zcl.library
.impl.general.GroupsCluster cannot be applied to (int,java.lang.String)
[ERROR] \ZB4Osgi\trunk\zigbee.ha.driver\src\main\java\it\cnr\isti\zigbee\ha\clus
ter\impl\ScenesImpl.java:[121,3] cannot find symbol
symbol : class RemoveAllScenesResponse
location: class it.cnr.isti.zigbee.ha.cluster.impl.ScenesImpl
[ERROR] \ZB4Osgi\trunk\zigbee.ha.driver\src\main\java\it\cnr\isti\zigbee\ha\clus
ter\impl\ScenesImpl.java:[121,39] cannot find symbol
symbol : class RemoveAllScenesResponse
location: class it.cnr.isti.zigbee.ha.cluster.impl.ScenesImpl
[ERROR] \ZB4Osgi\trunk\zigbee.ha.driver\src\main\java\it\cnr\isti\zigbee\ha\clus
ter\impl\ScenesImpl.java:[121,76] cannot find symbol
symbol : method removeAllScenes(int)
location: class it.cnr.isti.zigbee.zcl.library.impl.general.ScenesCluster


Related issues

blocks Bug #145: ON/OFF reporting by DimmableLight device Closed 10/21/2012

History

#1 Updated by Han Alink about 6 years ago

Error introduced with revision 529

#2 Updated by Stefano Lenzi about 6 years ago

  • Category set to zigbee.zcl.library
  • Status changed from New to Feedback
  • Assignee set to Stefano Lenzi
  • Priority changed from Urgent to Lowest
  • Target version set to org.aaloa.zb4osgi.zigbee.zcl.library-0.8.0

Cannot reproduce,
have you tried to updated to the latest version and clean compile everything?
You can test it by following the command

svn up
mvn clean install

from the trunk folder of your working copy?

#3 Updated by Han Alink about 6 years ago

Before updating this report stating that the error is "introduced with revision 529", I loaded a complete new copy of the ZB4Osgi software.
Loading up to 528 didn't show any problem. 529 still leads to the same compile error (also after clean up).

#4 Updated by Han Alink about 6 years ago

RemoveAllScene has been updated to RemoveAllScenes with bug fix #135!!!

#5 Updated by Stefano Lenzi about 6 years ago

The file RemoveAllScene.java should not be present nor it is referenced by the latest version of the code. While the file RemoveAllScenesResponse.java which is giving the error is available on SVN since r529, inside the zigbee.zcl.library artifact

I believe it is a problem of artifact resolution or not updated working copy.
I have checkout the project from scratch on a different machine and it compiled with issue, so try this steps:
  • checkout again the project on a different folder
  • delete your maven local repository (or you may try to delete only the .m2/repository/org/aaloa folder to avoid to download all the plugin and all external dependencies again)
  • execute mvn compile from command line

#6 Updated by Han Alink about 6 years ago

  • Status changed from Feedback to Closed

No errors anymore during compilation. I am closing the ticket.

Also available in: Atom PDF