Bug #145

ON/OFF reporting by DimmableLight device

Added by Han Alink over 5 years ago. Updated over 3 years ago.

Status:Closed Start date:10/21/2012
Priority:Low Due date:
Assignee:Stefano Lenzi % Done:

0%

Category:zigbee.tester Spent time: -
Target version:org.aaloa.zb4osgi.zigbee.tester-0.4.0
Has a patch:No Has license agreement signed:No

Description

When receiving ON/OFF reports from a MainsPowerOutlet device, the tester interface displays the status of the ON/OFF attribute every time it is sent:

Received Event from it.cnr.isti.zigbee.zcl.library.impl.core.AttributeImpl@16eb6bc with value true
Received Event from it.cnr.isti.zigbee.zcl.library.impl.core.AttributeImpl@16eb6bc with value true
Received Event from it.cnr.isti.zigbee.zcl.library.impl.core.AttributeImpl@16eb6bc with value true

When trying to achieve the same for a DimmableLight, the attribute status is not displayed in the Tester window.
Looking at the log file, the message with the status value is received by the software. In the attachment, both incoming messages are saved; I cannot see any difference.

onoffreporting.txt Magnifier (1.4 kB) Han Alink, 10/21/2012 07:18 pm


Related issues

blocked by Bug #143: compilation error Closed 10/21/2012

Associated revisions

Revision 550
Added by Stefano Lenzi about 5 years ago

Added data related to the HADevice owning the Attribute, it may help to ideintify the reporting issue ( refs #145 )

History

#1 Updated by Stefano Lenzi about 5 years ago

  • Category set to zigbee.tester
  • Status changed from New to In Progress
  • Assignee set to Stefano Lenzi
  • Priority changed from Normal to Low
  • Target version set to org.aaloa.zb4osgi.zigbee.tester-0.4.0

#2 Updated by Stefano Lenzi about 5 years ago

  • Status changed from In Progress to Feedback

It may be possible that there is any issue when subscribing twice on the same attribute from different clusters. Either only one subscription is actually performed or both subscription are notified as one.
Please update to latest version and report the new message on the LogPanel

Stefano

#3 Updated by Han Alink about 5 years ago

It's the same attribute, same cluster, different devices! I cannot update yet due to #143

#4 Updated by Han Alink about 5 years ago

Subscribing to the ON/OFF attribute of the DimmableLight: (no other attributes subscribed for)

adding device:Dimmable Light
Subscribed to OnOff
Status: SUCCESS

The message comes in every 20 seconds:

l - AF_INCOMIN_MSG arrived for 260:257:0@00:13:7A:00:00:00:81:D2:2 message is Pa
cket: length = 24, apiId = 0x44 0x81, full data = 0xfe 0x18 0x44 0x81 0x00 0x00
0x06 0x00 0xb1 0xb5 0x02 0x02 0x00 0x24 0x00 0xc4 0x6e 0x09 0x00 0x00 0x07 0x18
0x09 0x0a 0x00 0x00 0x10 0x00 0x54, checksum = 0x54, error = false, errorMessage = null
[ZToolPacketParser] DEBUG it.cnr.isti.zigbee.basedriver.api.impl.ZigBeeDeviceImp
l - Notifying 0 AFMessageConsumer
[ZToolPacketParser] INFO com.itaca.ztool.api.ZToolPacketParser - No data availab
le, waiting for new data event or timeout

Still no display of the status in the Tester window!!!

Subscribing to the ON/OFF attribute of the MainsPowerOutlet also succeeds:

adding device:Mains Power Outlet
Subscribed to OnOff
Status: SUCCESS

Though the reporting message is sent every 20 seconds, the logfile shows an error, and nothing is displayed in the Tester window:

ecieved AF_INCOMING_MSG notifying 1 listeners of Packet: length = 24, apiId = 0x
44 0x81, full data = 0xfe 0x18 0x44 0x81 0x00 0x00 0x06 0x00 0xf1 0x46 0x0a 0x02
0x00 0x37 0x00 0xa0 0x2d 0x0a 0x00 0x00 0x07 0x18 0x00 0x0a 0x00 0x00 0x10 0x00
0xd1, checksum = 0xd1, error = false, errorMessage = null
[ZToolPacketParser] DEBUG it.cnr.isti.zigbee.basedriver.api.impl.ZigBeeDeviceImp
l - AF_INCOMIN_MSG arrived for 260:9:0@00:13:7A:00:00:00:49:10:10 message is Pac
ket: length = 24, apiId = 0x44 0x81, full data = 0xfe 0x18 0x44 0x81 0x00 0x00 0
x06 0x00 0xf1 0x46 0x0a 0x02 0x00 0x37 0x00 0xa0 0x2d 0x0a 0x00 0x00 0x07 0x18 0
x00 0x0a 0x00 0x00 0x10 0x00 0xd1, checksum = 0xd1, error = false, errorMessage = null
[ZToolPacketParser] DEBUG it.cnr.isti.zigbee.basedriver.api.impl.ZigBeeDeviceImp
l - Notifying 0 AFMessageConsumer
[ZToolPacketParser] DEBUG it.cnr.isti.zigbee.basedriver.api.impl.ZigBeeDeviceImp
l - Notifying cluster listerner for recived by 260:9:0@00:13:7A:00:00:00:49:10:1
0
[ZToolPacketParser] DEBUG it.cnr.isti.zigbee.basedriver.api.impl.ZigBeeDeviceImp
l - Notifying 1 ClusterListner
[ZToolPacketParser] DEBUG it.cnr.isti.zigbee.zcl.library.impl.core.SubscriptionB
ase - Notifying 1 ReportListener
[ZToolPacketParser] DEBUG it.cnr.isti.zigbee.zcl.library.impl.core.SubscriptionB
ase - Notifying org.persona.zigbee.tester.gui.AttributeActionPanel$PanelLogRepor
tListener:org.persona.zigbee.tester.gui.AttributeActionPanel$PanelLogReportListe
ner@1ed1b0b
[ZToolPacketParser] ERROR it.cnr.isti.zigbee.zcl.library.impl.core.SubscriptionB
ase - Error while notifying org.persona.zigbee.tester.gui.AttributeActionPanel$P
anelLogReportListener:org.persona.zigbee.tester.gui.AttributeActionPanel$PanelLo
gReportListener@1ed1b0b caused by [org.persona.zigbee.tester.gui.AttributeAction
Panel$PanelLogReportListener.receivedReport(AttributeActionPanel.java:93), it.cn
r.isti.zigbee.zcl.library.impl.core.SubscriptionBase$ReportListenerNotifier.hand
leCluster(SubscriptionBase.java:88), it.cnr.isti.zigbee.basedriver.api.impl.ZigB
eeDeviceImpl.notifyClusterListner(ZigBeeDeviceImpl.java:474), it.cnr.isti.zigbee
.basedriver.api.impl.ZigBeeDeviceImpl.notify(ZigBeeDeviceImpl.java:506), it.cnr.
isti.zigbee.dongle.CC2530.impl.DriverCC2530$AFMessageListnerFilter.receivedAsync
hrounsCommand(DriverCC2530.java:190), it.cnr.isti.cc2480.high.HWHighLevelDriver.
notifyAsynchrounsCommand(HWHighLevelDriver.java:271), it.cnr.isti.cc2480.high.HW
HighLevelDriver$InternalPacketListener.packetReceived(HWHighLevelDriver.java:70)
, it.cnr.isti.cc2480.low.HWLowLevelDriver.notifyPacketListeners(HWLowLevelDriver
.java:270), it.cnr.isti.cc2480.low.HWLowLevelDriver.handlePacket(HWLowLevelDrive
r.java:322), com.itaca.ztool.api.ZToolPacketParser.run(ZToolPacketParser.java:11
3), java.lang.Thread.run(Unknown Source)]
[ZToolPacketParser] INFO com.itaca.ztool.api.ZToolPacketParser - No data availab
le, waiting for new data event or timeout

#5 Updated by Stefano Lenzi almost 5 years ago

  • Status changed from Feedback to In Progress

#6 Updated by Han Alink over 3 years ago

  • Status changed from In Progress to Closed

Tested again with Level Controllable Output (DIY) and Dimmable light (NetVox). Reporting On/Off for both devices is okay.
Closing the issue.

Also available in: Atom PDF