Improvement #162

No command result shown when type is Response in Tester

Added by Stefano Lenzi over 5 years ago. Updated over 3 years ago.

Status:Closed Start date:10/24/2012
Priority:Normal Due date:
Assignee:Stefano Lenzi % Done:

0%

Category:zigbee.tester Spent time: -
Target version:org.aaloa.zb4osgi.zigbee.tester-1.X
Has a patch:No Has license agreement signed:No

Description

ZigBee tester doesn't show any message when the result of method representing a Command returns an object of class Response


Related issues

blocks Bug #152: viewGroup command Closed 10/22/2012
blocks Bug #153: Get Group Membership Command payload Closed 10/22/2012

Associated revisions

Revision 571
Added by Stefano Lenzi over 5 years ago

Added dependencies with zigbee.cc2480.datalink due ByteUtils class with should be moved into zigbee.common
Displaying command result for all kind of response with a better message ( refs #162 )

Revision 618
Added by Stefano Lenzi about 5 years ago

Avoiding to print stacktrace when test succed
Added a more verbose output when showing Response packet as result of a command ( refs #162 )

History

#1 Updated by Stefano Lenzi over 5 years ago

A result should be displayed for all the response now ( at least the raw payload in hex format ).
Please let me know and close all the ticket if it is okay

#2 Updated by Han Alink over 5 years ago

The reported ONOFF attribute is no longer shown in the tester interface window. I did not test other attributes (yet).

13:22:44.721 - DEBUG - [ZToolPacketParser] it.cnr.isti.zigbee.basedriver.api.im
pl.ZigBeeDeviceImpl - AF_INCOMIN_MSG arrived for 260:257:0@00:13:7A:00:00:00:81:
D2:1 message is Packet: length = 24, apiId = 0x44 0x81, full data = 0xfe 0x18 0x
44 0x81 0x00 0x00 0x06 0x00 0x00 0x00 0x0d 0x02 0x00 0xff 0x00 0x00 0x00 0x00 0x
00 0x00 0x07 0x18 0x00 0x0a 0x00 0x00 0x10 0x00 0x2e, checksum = 0x2e, error = f
alse, errorMessage = null

#3 Updated by Han Alink over 5 years ago

Additional information:
After the AF_INCOMING_MSG (There is a typo error;INCOMIN should read INCOMING) the following error is reported:
13:31:58.791 - ERROR - [ZToolPacketParser] it.cnr.isti.zigbee.zcl.library.impl.
core.SubscriptionBase - Error while notifying org.persona.zigbee.tester.gui.Attr
ibuteActionPanel$PanelLogReportListener:org.persona.zigbee.tester.gui.AttributeA
ctionPanel$PanelLogReportListener@1e184cb caused by [org.persona.zigbee.tester.g
ui.AttributeActionPanel$PanelLogReportListener.receivedReport(AttributeActionPan
el.java:93), it.cnr.isti.zigbee.zcl.library.impl.core.SubscriptionBase$ReportLis
tenerNotifier.handleCluster(SubscriptionBase.java:88), it.cnr.isti.zigbee.basedr
iver.api.impl.ZigBeeDeviceImpl.notifyClusterListner(ZigBeeDeviceImpl.java:474),
it.cnr.isti.zigbee.basedriver.api.impl.ZigBeeDeviceImpl.notify(ZigBeeDeviceImpl.
java:506), it.cnr.isti.zigbee.dongle.CC2530.impl.DriverCC2530$AFMessageListnerFi
lter.receivedAsynchrounsCommand(DriverCC2530.java:190), it.cnr.isti.cc2480.high.
HWHighLevelDriver.notifyAsynchrounsCommand(HWHighLevelDriver.java:271), it.cnr.i
sti.cc2480.high.HWHighLevelDriver$InternalPacketListener.packetReceived(HWHighLe
velDriver.java:70), it.cnr.isti.cc2480.low.HWLowLevelDriver.notifyPacketListener
s(HWLowLevelDriver.java:270), it.cnr.isti.cc2480.low.HWLowLevelDriver.handlePack
et(HWLowLevelDriver.java:322), com.itaca.ztool.api.ZToolPacketParser.run(ZToolPa
cketParser.java:113), java.lang.Thread.run(Unknown Source)]
13:31:58.791 - ERROR - [ZToolPacketParser] it.cnr.isti.zigbee.zcl.library.impl.
core.SubscriptionBase - Error while notifying org.persona.zigbee.tester.gui.Attr
ibuteActionPanel$PanelLogReportListener:org.persona.zigbee.tester.gui.AttributeA
ctionPanel$PanelLogReportListener@1e184cb caused by [org.persona.zigbee.tester.g
ui.AttributeActionPanel$PanelLogReportListener.receivedReport(AttributeActionPan
el.java:93), it.cnr.isti.zigbee.zcl.library.impl.core.SubscriptionBase$ReportLis
tenerNotifier.handleCluster(SubscriptionBase.java:88), it.cnr.isti.zigbee.basedr
iver.api.impl.ZigBeeDeviceImpl.notifyClusterListner(ZigBeeDeviceImpl.java:474),
it.cnr.isti.zigbee.basedriver.api.impl.ZigBeeDeviceImpl.notify(ZigBeeDeviceImpl.
java:506), it.cnr.isti.zigbee.dongle.CC2530.impl.DriverCC2530$AFMessageListnerFi
lter.receivedAsynchrounsCommand(DriverCC2530.java:190), it.cnr.isti.cc2480.high.
HWHighLevelDriver.notifyAsynchrounsCommand(HWHighLevelDriver.java:271), it.cnr.i
sti.cc2480.high.HWHighLevelDriver$InternalPacketListener.packetReceived(HWHighLe
velDriver.java:70), it.cnr.isti.cc2480.low.HWLowLevelDriver.notifyPacketListener
s(HWLowLevelDriver.java:270), it.cnr.isti.cc2480.low.HWLowLevelDriver.handlePack
et(HWLowLevelDriver.java:322), com.itaca.ztool.api.ZToolPacketParser.run(ZToolPa
cketParser.java:113), java.lang.Thread.run(Unknown Source)]

#4 Updated by Han Alink over 5 years ago

I had my temperature sensor updated by SimpleHomeNet as it did not support Configure Reporting.
Now it does respond, but the response does not generate a message in the tester window with the measured value.I'm using revision 584 now.
The incoming message looks okay; here it is:

12:46:04.522 - DEBUG - [ZToolPacketParser] it.cnr.isti.zigbee.basedriver.api.im
pl.ZigBeeDeviceImpl - AF_INCOMIN_MSG arrived for 260:770:0@00:13:7A:00:00:00:28:
02:10 message is Packet: length = 25, apiId = 0x44 0x81, full data = 0xfe 0x19 0
x44 0x81 0x00 0x00 0x02 0x04 0x56 0xc4 0x0a 0x03 0x00 0x41 0x00 0x21 0xf5 0x07 0
x00 0x00 0x08 0x18 0x12 0x0a 0x00 0x00 0x29 0x84 0x07 0x71, checksum = 0x71, err
or = false, errorMessage = null
12:46:04.532 - DEBUG - [ZToolPacketParser] it.cnr.isti.zigbee.basedriver.api.im
pl.ZigBeeDeviceImpl - Notifying 0 AFMessageConsumer
12:46:04.532 - DEBUG - [ZToolPacketParser] it.cnr.isti.zigbee.basedriver.api.im
pl.ZigBeeDeviceImpl - Notifying 0 AFMessageConsumer

#5 Updated by Han Alink about 5 years ago

I found that the reports of some devices are displayed and some are not.
Looking closer to the debug output, I found that the devices of which the status is not reported do not contain the debug line: "Notifying 1 ClusterListner".
In all cases, setting the report interval is reported as successful, and the reports are received as expected.

#6 Updated by Stefano Lenzi about 5 years ago

  • Status changed from New to Resolved

Please confirm that some sort of notification is shown on the Tester panel when invoking a cluster command.
The reporting issue is not consider in this topic, if you are expecting other issue on reporting please create a new ticket.

If you agree, please close the ticket

#7 Updated by Han Alink about 5 years ago

I'm not sure what you mean; what cluster command?

#8 Updated by Stefano Lenzi about 5 years ago

With the terms Command I means any request sent to a device. At the begining the ZigBee Tester shown the result of such request if and only if the response was a String message, while the current code should shows always something.
In particular, it should shows at least the raw ZCLFrame in case that no valid Formatter is available.

#9 Updated by Han Alink about 5 years ago

1) A On or Off command does not lead to a displayed response message (though that is also a request!).
2) I indeed saw a ZCL frame contents displayed when I was testing the WRITE behavior of the "PhysicalEnvironment" attribute of the basic cluster.
Note: I solved that one; the error was due to a wrong attribute description in the TI HA sample application.

#10 Updated by Stefano Lenzi over 3 years ago

  • Status changed from Resolved to Closed

Han Alink wrote:

1) A On or Off command does not lead to a displayed response message (though that is also a request!).

Yes, default response is enabled, but the "glue code" for the OnOff cluster (see source:trunk/zigbee.ha.driver/src/main/java/it/cnr/isti/zigbee/ha/cluster/impl/OnOffImpl.java ) defines the method as void so no response is displayed, but no exception in that case means that a Default Response command with SUCCESS status was recieved

2) I indeed saw a ZCL frame contents displayed when I was testing the WRITE behavior of the "PhysicalEnvironment" attribute of the basic cluster.
Note: I solved that one; the error was due to a wrong attribute description in the TI HA sample application.

When writing an attribute with the Tester no ZCL frame should be displayed but only some human readable message like: "Set attribute ... to ... SUCCESS"

Also available in: Atom PDF