Bug #163

dimmable Light

Added by Han Alink almost 6 years ago. Updated about 4 years ago.

Status:Closed Start date:10/27/2012
Priority:Lowest Due date:
Assignee:Stefano Lenzi % Done:

0%

Category:zigbee.zcl.library Spent time: -
Target version:org.aaloa.zb4osgi.zigbee.zcl.library-1.X
Has a patch:No Has license agreement signed:No

Description

Typo errors:
OnOffTRansationTime should read OnOffTransitionTime.
StopWithOnOff should read MoveWithOnOff

stopWithOnOff.jpg (70.9 kB) Han Alink, 09/04/2013 11:03 am


Related issues

blocked by Bug #180: Problem discovering devices after revision 584 Closed 02/01/2013

Associated revisions

Revision 575
Added by Stefano Lenzi almost 6 years ago

Fixing typo ( fixes #166, refs #163 )

Revision 620
Added by Stefano Lenzi over 5 years ago

Fixing type in OnOffTransitionTime ( refs #163 )

Revision 1046
Added by Stefano Lenzi about 4 years ago

Removed the command StopWithOnOff from LevelControl because it is not defined in ZigBee Cluster Library ( refs #163 )

History

#1 Updated by Stefano Lenzi almost 6 years ago

  • Category set to zigbee.zcl.library
  • Status changed from New to Feedback
  • Assignee set to Stefano Lenzi
  • Priority changed from Normal to Lowest
  • Target version set to org.aaloa.zb4osgi.zigbee.zcl.library-1.X

Fixed the typo for OnOffTransitionTime

I don't understand which is the issue with the MoveWithOnOff command, for my understanding both of them should exist

#2 Updated by Han Alink almost 6 years ago

StopWithOnOff is not a valid command (should be deleted)
MoveWithOnOff is not available, so should be added
(NB: StepWithOnOff is a valid command, but this one exists already)

#3 Updated by Han Alink almost 6 years ago

TransationTime should read TransistionTime

#4 Updated by Stefano Lenzi over 5 years ago

  • Status changed from Feedback to Resolved

It should be fixed, in case that you agree please close the ticket

#5 Updated by Han Alink over 5 years ago

I cannot test this because the device is not detected/shown by ZB4O (related to bug #180).

#6 Updated by Han Alink over 5 years ago

There is still a network join problem with this device.
I first have to talk to NetVox about the factory reset operation.

#7 Updated by Stefano Lenzi over 5 years ago

  • Status changed from Resolved to Closed

I will close the ticket because the issue is no more related to the typo but to network joining of the device and it seems to be a vendor issue rather then a software issue, so we can consider the original bug fixed. Please open a new issue in case that the network join is blocked by ZB4O ( even if ZB4O do not handle at all the network joining so it rarely be the cause )

#8 Updated by Han Alink over 5 years ago

  • Status changed from Closed to Reopen

StopWithOnOff is still shown as a command for the LevelControl cluster.
This is not a valid command.

#9 Updated by Han Alink almost 5 years ago

Added screen dump to show undefined cluster (revision 803)

#10 Updated by Stefano Lenzi about 4 years ago

  • Status changed from Reopen to Feedback

Removed the StopWithOnOff command from the cluster as pointed out, please close it if you agree with the patch

#11 Updated by Stefano Lenzi about 4 years ago

  • Status changed from Feedback to Resolved

#12 Updated by Han Alink about 4 years ago

  • Status changed from Resolved to Closed

Okay; I close the issue

Also available in: Atom PDF