Bug #191

Revision 663

Added by Han Alink almost 5 years ago. Updated almost 5 years ago.

Status:Closed Start date:03/01/2013
Priority:Urgent Due date:
Assignee:Stefano Lenzi % Done:

100%

Category:zigbee.ha.driver Spent time: -
Target version:org.aaloa.zb4osgi.zigbee.ha.driver-0.7.0
Has a patch:No Has license agreement signed:No

Description

1) It's not possible do do a error free maven run without skipping the testunits
2) The classes in the ha drive device factory are missing

Associated revisions

Revision 664
Added by Stefano Lenzi almost 5 years ago

An old import in Activator was breaking the compilation of the project ( refs #191 )

Revision 668
Added by Stefano Lenzi almost 5 years ago

Committing missing files after refactoring of ZigBeeType ( fixes #191 )

History

#1 Updated by Stefano Lenzi almost 5 years ago

  • Category set to zigbee.ha.driver
  • Status changed from New to Resolved
  • Assignee set to Stefano Lenzi
  • Target version set to org.aaloa.zb4osgi.zigbee.ha.driver-0.7.0

Problem caused by a import left after patch the trunk with #179
Fixed with r664

#2 Updated by Han Alink almost 5 years ago

  • Status changed from Resolved to Reopen

Ha device factories still not available in ha bundle

#3 Updated by Stefano Lenzi almost 5 years ago

  • Status changed from Reopen to Feedback

HA device factories code has been removed from your patch and it has been replaced with source:/trunk/zigbee.ha.driver/src/main/java/it/cnr/isti/zigbee/ha/driver/core/GenericHADeviceFactory.java so it is not going to be included.

Do you have any reason for including such code?

#4 Updated by Han Alink almost 5 years ago

Okay
I also find a compilation failure in the tester bundle:
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.
3.2:compile (default-compile) on project org.aaloa.zb4osgi.zigbee.tester: Compil
ation failure: Compilation failure:
[ERROR] \zbnew\zigbee.tester\src\main\java\org\persona\zigbee\tester\gui\Attribu
teActionPanel.java:[33,47] cannot find symbol
[ERROR] symbol : class ZigBeeType
[ERROR] location: package it.cnr.isti.zigbee.zcl.library.impl.core
[ERROR] \zbnew\zigbee.tester\src\main\java\org\persona\zigbee\util\Converter.jav
a:[26,47] cannot find symbol
[ERROR] symbol : class ZigBeeType
[ERROR] location: package it.cnr.isti.zigbee.zcl.library.impl.core
[ERROR] \zbnew\zigbee.tester\src\main\java\org\persona\zigbee\util\Converter.jav
a:[37,47] cannot find symbol
[ERROR] symbol : class ZigBeeType
[ERROR] location: class org.persona.zigbee.util.Converter
[ERROR] \zbnew\zigbee.tester\src\main\java\org\persona\zigbee\tester\gui\Attribu
teActionPanel.java:[213,11] cannot find symbol
[ERROR] symbol: class ZigBeeType
[ERROR] final ZigBeeType type = attribute.getZigBeeType();
[ERROR] -> [Help 1]

#5 Updated by Stefano Lenzi almost 5 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Applied in changeset r668.

Also available in: Atom PDF