Improvement #193

BinaryInput cluster

Added by Han Alink over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:03/04/2013
Priority:Normal Due date:
Assignee:Stefano Lenzi % Done:

0%

Category:zigbee.ha.driver Spent time: -
Target version:org.aaloa.zb4osgi.zigbee.ha.driver-0.7.0
Has a patch:No Has license agreement signed:No

Description

Related to issue #182:
The BinaryInput cluster has a method getPresentValue() that retrieves the boolean value of the PresentValue attribute.
The BinaryInput cluster should also have a method: getPresentValue() to retrieve the PresentValue attribute. (Other clusters do have these methods).
(The same accounts for the other attributes of the BinaryInput cluster)

History

#1 Updated by Stefano Lenzi over 5 years ago

  • Category set to zigbee.ha.driver
  • Status changed from New to Feedback
  • Assignee set to Stefano Lenzi
  • Target version set to org.aaloa.zb4osgi.zigbee.ha.driver-0.7.0

Actually the BinaryInput is one of the few cluster that respects the initial ZB4O. In fact, at HA Driver level the cluster should provide to the actual contenct of the attribute rather then to the Attribute object which should be hidden.
If the developer wants to access to Attribute object it should use a code light this:

SimpleSensor device = ...
BinaryInput bi = device.getBinaryInput();
Attribute presentValue = bi.getAttribute(Attributes.PRESENT_VALUE.getId());

So the problem is that we should review all the interface and implementation of it.cnr.isti.zigbee.ha.cluster.glue for avoiding to return a generic Attribute instead of the value of attribute itself. As side effect we should also define method setXXX(object X) for attributes that are writeable

#2 Updated by Han Alink over 5 years ago

  • Status changed from Feedback to Closed

Okay; I'll close this item (and also #182)

Also available in: Atom PDF