Bug #209

clusterListeners

Added by Han Alink over 5 years ago. Updated almost 4 years ago.

Status:New Start date:03/18/2013
Priority:High Due date:
Assignee:Giancarlo Riolo % Done:

0%

Category:zigbee.zcl.library Spent time: -
Target version:org.aaloa.zb4osgi.zigbee.zcl.library-0.9.0
Has a patch:No Has license agreement signed:No

Description

I have a device (ID= 0x302) that has implemented 2 clusters (Temperature (0x0402) and Humidity Measurement (0x0405)).
My application subscribes to the TemperatureValue and HumidityValue attribute.
Both reports are received from the device and reported to my application. So from an application point of view everything is fine!

But every time a report is received, 2 ClusterListeners are informed (instead of one). This leads to an exception:
it.cnr.isti.zigbee.zcl.library.api.core.ZigBeeClusterException: Expected Response for cluster Id: 1026 but received message for cluster Id: 1029
or (if the other value is received):
it.cnr.isti.zigbee.zcl.library.api.core.ZigBeeClusterException: Expected Response for cluster Id: 1029 but received message for cluster Id: 1026

History

#1 Updated by Stefano Lenzi over 4 years ago

  • Category set to zigbee.zcl.library
  • Assignee set to Giancarlo Riolo
  • Priority changed from Normal to High
  • Target version set to org.aaloa.zb4osgi.zigbee.zcl.library-0.8.0

It looks like that iether the ClusterListener registered by the ZCL layer is not correct or the dispatching of even from the ZigBee Base Driver is not correct

#2 Updated by Stefano Lenzi almost 4 years ago

  • Target version changed from org.aaloa.zb4osgi.zigbee.zcl.library-0.8.0 to org.aaloa.zb4osgi.zigbee.zcl.library-0.9.0

Moved to next release

Also available in: Atom PDF