Activity

From 09/30/2012 to 10/29/2012

10/29/2012

11:05 am Bug #167 (Closed): ResetAlarm command of Alarms cluster
The following exception is thrown when issuing this command with the values 1 for both integers.
==== Action:: Ala...
Han Alink
10:51 am Bug #166 (Closed): PowerConfigurationCluster
Typo error: attribute BatteryManufaturer should read BatteryManufacturer Han Alink
10:38 am Bug #165 (In Progress): Relative Humidity Measurement Cluster not shown
The RelativeHumidityMeasurement cluster is not shown in the tester interface Han Alink

10/28/2012

06:10 pm Bug #164 (Closed): dimmable light, step command
Applied in changeset r573. Stefano Lenzi
05:49 pm Bug #164 (Resolved): dimmable light, step command
it should be fixed with r573, if it is please close the ticket
Stefano Lenzi
05:48 pm Revision 573: Add Unit test for step Command
Using ByteArrayStreamSerializer instead of DefaultSerializer ( fixes #164) Stefano Lenzi
04:09 pm Wish #154 (Rejected): debug info in CMD window
Stefano Lenzi

10/27/2012

06:56 pm Bug #151 (Closed): Identify attribute value problem
I think everything is okay now; I'm closing the issue Han Alink
06:17 pm Bug #164 (Closed): dimmable light, step command
Trying to step with the values 0 (=up), 20 (stepsize) and 100 (transition time 10 seconds) leads to an error:
====...
Han Alink
06:14 pm Bug #163 (Closed): dimmable Light
Typo errors:
OnOffTRansationTime should read OnOffTransitionTime.
StopWithOnOff should read MoveWithOnOff
Han Alink
01:36 pm Improvement #162: No command result shown when type is Response in Tester
Additional information:
After the AF_INCOMING_MSG (There is a typo error;INCOMIN should read INCOMING) the following...
Han Alink
01:25 pm Improvement #162: No command result shown when type is Response in Tester
The reported ONOFF attribute is no longer shown in the tester interface window. I did not test other attributes (yet)... Han Alink
12:24 pm Wish #154: debug info in CMD window
For some reason the logging bundle changed from bundle 6 to 7. I did not notice that and kept starting 6 instead of 7... Han Alink

10/26/2012

04:37 pm Revision 572: firmware folder
Manlio Bacco
11:29 am Improvement #162: No command result shown when type is Response in Tester
A result should be displayed for all the response now ( at least the raw payload in hex format ).
Please let me know...
Stefano Lenzi
11:27 am Revision 571: Added dependencies with zigbee.cc2480.datalink due ByteUtils class with should be m...
Displaying command result for all kind of response with a better message ( refs #162 ) Stefano Lenzi

10/25/2012

04:24 pm Wish #154: debug info in CMD window
I wasn't saying that you changed the configuration (even if you may lost it when you deleted your working copy and yo... Stefano Lenzi
04:15 pm Bug #150 (Closed): Enabling get* commands leads to unwanted commands in tester interface
Fixed Han Alink
04:03 pm Wish #154: debug info in CMD window
I did not change a single line in this configuration file; it's the same as I have always used. Nevertheless, since 2... Han Alink
10:43 am Wish #154: debug info in CMD window
The configuration of the logging system depends on the way you are using for executing the project. If you are using ... Stefano Lenzi
10:23 am Bug #150: Enabling get* commands leads to unwanted commands in tester interface
I hope it is working as expected now, please give it a try and close the ticket in case Stefano Lenzi
10:22 am Revision 570: Added Test Unit for checking the method that are identified as command from the tes...
Changed again policy for identifying the command among the methods of a cluster object ( refs #150 ) Stefano Lenzi

10/24/2012

04:22 pm Bug #159 (Closed): Deadlock in the SimpleDriver when Exception is thrown
The fix seems to be working Stefano Lenzi
03:22 pm Revision 569: Folder to save the initial contribution of TSB on x73
Francesco Furfari
03:00 pm Wish #154: debug info in CMD window
I still have problems with the logging of data.
Every time I move the mouse or make a mouseclick in the tester windo...
Han Alink
02:15 pm Bug #151: Identify attribute value problem
Several commands and attributes (e.g. Basic Cluster: reset to fac..., Identify Cluster: Identify, Identify Query etc.... Han Alink
01:48 pm Bug #151: Identify attribute value problem
My bad, sorry!
I have relied on eclipse rather then Maven thus I have skipped test unit.
Please give it a try again
Stefano Lenzi
01:47 pm Revision 568: Test for valid byte value was missing a NOT and caused Test Unit failure ( refs #151 )
Stefano Lenzi
01:14 pm Wish #154: debug info in CMD window
Anyway you can have a look at this "log4j properties":http://logback.qos.ch/translator/ that will be used for configu... Stefano Lenzi
01:09 pm Bug #151: Identify attribute value problem
This change has led to a compile error:
[INFO] Reactor Summary:
[INFO]
[INFO] OSGi and Primitive Types Utility ....
Han Alink
12:58 pm Wish #154 (In Progress): debug info in CMD window
Manlio can you describe the way to configure the logging on the wiki? Stefano Lenzi
12:55 pm Improvement #162 (Closed): No command result shown when type is Response in Tester
ZigBee tester doesn't show any message when the result of method representing a _Command_ returns an object of class ... Stefano Lenzi
12:34 pm Bug #151 (Feedback): Identify attribute value problem
Manlio or Han, can you check if the exception is gone?
If it is please close the ticket
P.S.: If you set log leve...
Stefano Lenzi
12:24 pm Revision 567: We consider valid byte data all the int that could be represented in with 8 bits ( ...
Stefano Lenzi
11:49 am Bug #150: Enabling get* commands leads to unwanted commands in tester interface
I'm afraid that there is no definitive solution for it, because we are using standard Java reflection for identifying... Stefano Lenzi
11:49 am Revision 566: Changed again the policy for identifyin command among the methods of a Cluster ( re...
Stefano Lenzi
10:04 am Bug #150: Enabling get* commands leads to unwanted commands in tester interface
The unwanted "Get" commands are gone, but also the Identify Query command disappeared! Han Alink
09:42 am Bug #150 (Feedback): Enabling get* commands leads to unwanted commands in tester interface
Please give it a try and close the ticket if it works Stefano Lenzi
09:42 am Bug #140 (Closed): ZigBeeTester doesn't shows command whose name starts with get
Stefano Lenzi
09:38 am Revision 565: Trying to show only the Command on the ZigBee Tester ( refs #150 )
Stefano Lenzi

10/23/2012

06:01 pm Revision 564: Better log messages for identifying deadlocks
Fixed deadlock issue when exception thrown by sendSynchrouns method ( refs #159 ) Stefano Lenzi
05:56 pm Bug #160 (Closed): Error in ZToolPacket.toString()
Manlio Bacco
05:56 pm Bug #151: Identify attribute value problem
closing #160, it's a duplicate one. Manlio Bacco
05:51 pm Improvement #158 (Closed): Add support for array type in ZigBee Tester
okay Francesco Furfari
05:48 pm Bug #160 (Closed): Error in ZToolPacket.toString()
17:36:19.622 - INFO - [DEMO AAL] it.cnr.isti.zigbee.dongle.CC2530.impl.DriverCC2530 - Se
nding Synchrouns com.itac...
Manlio Bacco
05:46 pm Bug #151 (In Progress): Identify attribute value problem
The issue should not be fixed, because I have changed only the message of the exception, please notify us as soon as ... Stefano Lenzi
05:42 pm Bug #159 (Closed): Deadlock in the SimpleDriver when Exception is thrown
If an exception is thrown between a waitAndLock3WayConversation(ZToolPacket) and unLock3WayConversation(ZToolPacket) ... Stefano Lenzi
04:50 pm Bug #153: Get Group Membership Command payload
Tried another device. It's probably not a device issue.
The ZCL frame received : 0x09 0x18 0x02 0x07 0x01 0x0f 0x00 ...
Han Alink
04:41 pm Revision 563
Manlio Bacco
04:40 pm Revision 562
Manlio Bacco
04:37 pm Revision 561
Manlio Bacco
04:37 pm Revision 560
Manlio Bacco
04:36 pm Revision 559: cosmetic fixes
Manlio Bacco
04:05 pm Bug #150 (In Progress): Enabling get* commands leads to unwanted commands in tester interface
We have to change the algorithm for identifying command among the method of the Cluster class Stefano Lenzi
03:59 pm Bug #153: Get Group Membership Command payload
I think the exception thrown now is correct, and it's a problem with the device(ZBMLC15). I'll try with another devic... Han Alink
03:53 pm Bug #153: Get Group Membership Command payload
Last update message incorrect; should discarded. Han Alink
03:46 pm Bug #153: Get Group Membership Command payload
No error message anymore, but the name of the group is not displayed in the tester window. Han Alink
03:35 pm Bug #153 (Feedback): Get Group Membership Command payload
The problem was the support for Array types as parameter ( see #158 )
It should be working now, please let me know a...
Stefano Lenzi
03:34 pm Improvement #158 (Resolved): Add support for array type in ZigBee Tester
Initial support provided by separating each element of the array with comma or semicolon.
For example the String "10...
Stefano Lenzi
03:32 pm Revision 558: Initial support for Array types ( refs #158 )
Stefano Lenzi
03:31 pm Improvement #158 (Closed): Add support for array type in ZigBee Tester
Invoking command with array parameter is not support.
We should provide a minimal interface for letting the user pla...
Stefano Lenzi
02:14 pm Bug #153: Get Group Membership Command payload
We still have a problem here. Trying to execute the getGroupMembership command shows the following error:
(Also the ...
Han Alink
02:04 pm Bug #152: viewGroup command
No exception anymore, but the name of the group is not displayed in the tester window. Han Alink
02:01 pm Bug #151 (Closed): Identify attribute value problem
No exception anymore.
I'm closing the ticket.
Han Alink
01:51 pm Bug #134 (Closed): addGroupIfIdentifying Command
Han Alink
12:34 pm Bug #153 (In Progress): Get Group Membership Command payload
The Java class representing _Get Group Membership Command_ defines only a int[] parameter, because the GroupCount par... Stefano Lenzi
12:30 pm Revision 557: Adde Test Unit GetGroupMembership and fixed automatic generation of Group Count fie...
Stefano Lenzi
12:16 pm Bug #151 (Feedback): Identify attribute value problem
The issue is cause by the conversion of ZToolPacket into String during the generation of a log line, it doesn't seems... Stefano Lenzi
12:13 pm Revision 556: Trying to figure out the Exception thrown during the converstion of ZToolPacket to ...
Stefano Lenzi
12:00 pm Bug #152 (Feedback): viewGroup command
The issue was related to the parsing of all the "String" data of ZigBee it should be fixed Stefano Lenzi
11:50 am Revision 555: Updated svn properties of files
Stefano Lenzi
11:49 am Revision 554: Verified and fixed parsing of "View Group Response" command ( refs #152 )
Adde Test Unit for verification of the parsing Stefano Lenzi

10/22/2012

08:12 pm Wish #154 (Rejected): debug info in CMD window
Is it possible to switch of some of the debug info in the command window?
Since the last update all events (mouse cl...
Han Alink
08:00 pm Bug #153 (Closed): Get Group Membership Command payload
The Get Group Membership Command has 2 parameters: GroupCount and GroupList.
Only one is available in the tester in...
Han Alink
07:51 pm Bug #152 (Closed): viewGroup command
After setting a Group (16) with a name (abc), the viewGroup leads to the following incomming message:
Packet: length...
Han Alink
06:12 pm Bug #151 (Closed): Identify attribute value problem
When trying to set the Identify time, a value of e.g. 200 leads to: (though it's a 16 bit attribute)
==== Action:: I...
Han Alink
05:50 pm Bug #150 (Closed): Enabling get* commands leads to unwanted commands in tester interface
Though some "get*" commands now are taken into account, also a number of unwanted "get*" commands pop up in the teste... Han Alink
05:38 pm Bug #145: ON/OFF reporting by DimmableLight device
Subscribing to the ON/OFF attribute of the DimmableLight: (no other attributes subscribed for)
> adding device:Dim...
Han Alink
05:18 pm Bug #147 (Closed): Groups, Scenes, and Alarms response were expecting General frame
Fixed. Han Alink
05:16 pm Bug #134: addGroupIfIdentifying Command
Fixed. Han Alink
05:04 pm Bug #143 (Closed): compilation error
No errors anymore during compilation. I am closing the ticket. Han Alink
05:03 pm Bug #144 (Closed): svn update problem
Yes! I close this ticket and ticket 143. Han Alink
05:00 pm Bug #143: compilation error
The file RemoveAllScene.java should not be present nor it is referenced by the latest version of the code. While the ... Stefano Lenzi
04:46 pm Bug #144: svn update problem
Can you try to perform the check out again the working copy on a different folder with the following command... Stefano Lenzi
04:31 pm Revision 553: Updated Basic cluster with the new attribute DisableLocalConfig
Stefano Lenzi
04:29 pm Bug #134 (Feedback): addGroupIfIdentifying Command
It should be fixed now, I have also added a Test Unit for catching similar issue.
Please let me know
Stefano Lenzi
04:28 pm Revision 552: Fixing NPE when setting non-numeric parameter ( refs #134 )
Added Test Case for matching similar issue Stefano Lenzi
04:10 pm Bug #133 (Closed): Missing Parameters Group commands
You are missing nothing; I was missing the latest release of the document. Sorry ...
Assuming that the GroupName and...
Han Alink
03:59 pm Bug #145: ON/OFF reporting by DimmableLight device
It's the same attribute, same cluster, different devices! I cannot update yet due to #143 Han Alink
03:56 pm Bug #143: compilation error
RemoveAllScene has been updated to RemoveAllScenes with bug fix #135!!! Han Alink
03:51 pm Bug #143: compilation error
Before updating this report stating that the error is "introduced with revision 529", I loaded a complete new copy of... Han Alink
03:44 pm Bug #144: svn update problem
Updating only the trunk shows the same error:
Command: Update
Error: Server sent unexpected return value (403 For...
Han Alink
01:55 pm Revision 551
Ennio Grasso
01:42 pm Bug #145 (Feedback): ON/OFF reporting by DimmableLight device
It may be possible that there is any issue when subscribing twice on the same attribute from different clusters. Eith... Stefano Lenzi
01:39 pm Revision 550: Added data related to the HADevice owning the Attribute, it may help to ideintify t...
Stefano Lenzi
01:04 pm Bug #145 (In Progress): ON/OFF reporting by DimmableLight device
Stefano Lenzi
11:11 am Bug #147 (Feedback): Groups, Scenes, and Alarms response were expecting General frame
It should be fixed, please test it and let us know Stefano Lenzi
11:10 am Revision 549: Checking for specific command response rather then cluster wide response ( refs #147 )
Stefano Lenzi
11:09 am Bug #147 (Closed): Groups, Scenes, and Alarms response were expecting General frame
The parsing of the Response command of the cluster Groups, Scenes, and Alarms were checking for General frame bit to ... Stefano Lenzi
10:54 am Revision 548: No change, only cleaning the code by removing unused import
Stefano Lenzi
10:50 am Bug #139 (Closed): Identify command
Created #146 for improving the ZigBee Tester UI/UX Stefano Lenzi
10:49 am Improvement #146 (New): Creating specialized input field for definig command parameter
At the moment the user can type any value for any command parameter, which lead to confusion when a user type a strin... Stefano Lenzi
10:38 am Bug #133: Missing Parameters Group commands
Dear Han,
I'm missing something, by looking to the latest ZCL Specifaction (updated to May'12) available from "ZigBe...
Stefano Lenzi
10:23 am Revision 547: Update ZCL from May'07 to May'12 version
Update HA from 1.0 to 1.1 version Stefano Lenzi
10:03 am Bug #143 (Feedback): compilation error
Cannot reproduce,
have you tried to updated to the latest version and clean compile everything?
You can test it by ...
Stefano Lenzi
09:34 am Revision 546
Ennio Grasso
09:34 am Revision 545
Ennio Grasso
09:33 am Revision 544
Ennio Grasso
09:33 am Revision 543
Ennio Grasso
09:32 am Revision 542
Ennio Grasso
09:27 am Revision 541
Ennio Grasso
09:26 am Revision 540
Ennio Grasso
09:19 am Bug #144 (Feedback): svn update problem
It's an issue related to the creation of the "private" area on the SVN, at the moment the workaround is to update san... Stefano Lenzi
09:17 am Revision 539
Ennio Grasso
09:17 am Revision 538
Ennio Grasso

10/21/2012

07:18 pm Bug #145 (Closed): ON/OFF reporting by DimmableLight device
When receiving ON/OFF reports from a MainsPowerOutlet device, the tester interface displays the status of the ON/OFF ... Han Alink
05:07 pm Bug #139: Identify command
Problem solved Han Alink
05:00 pm Bug #134: addGroupIfIdentifying Command
After setting the device in identify mode, issuing a addGroupIfIdentifying command with the 2 parameters leads to a n... Han Alink
04:48 pm Bug #143: compilation error
Error introduced with revision 529 Han Alink
02:38 pm Bug #133: Missing Parameters Group commands
According to the ZCL spec, the View Group command should be sent with the GroupID as parameter.
The name of the Grou...
Han Alink
02:32 pm Bug #144 (Closed): svn update problem
Updating my local version leads to the following error:
Command: Update
Error: Server sent unexpected return va...
Han Alink
02:29 pm Bug #143 (Closed): compilation error
Trying to install the latest revision (532) leads to a compilation error:
[ERROR] COMPILATION ERROR :
[INFO] ----...
Han Alink

10/20/2012

08:01 pm Private area for members
We just created the "members" location on the SVN server to allow the members to share documents, software, and other... Stefano Lenzi
07:57 pm Telecom Italia joined the project
"Telecom Italia":http://www.telecomitalia.it/ joined ZB4O by contributing with an implementationof the ZGD "vote resu... Stefano Lenzi
07:48 pm Revision 537: Added Dongle specification
Added ZigBee specification
Added Tool from Texas Instrument
Added Tool for Serial Port Monitoring
Stefano Lenzi
07:08 pm Revision 536: A space for sharing documentation (i.e. specification, data sheet, and so on)
Stefano Lenzi
07:02 pm Revision 535: Creating a folder for sharing stuff in private mode among the ZB4O members
Stefano Lenzi

10/19/2012

06:37 pm Revision 534: Inizial commit made by Telecom Italia to setup the GAL project for the ZB4OSGi group.
Andrea Ranalli
05:45 pm Revision 533
Manlio Bacco
05:36 pm Bug #140 (Rejected): ZigBeeTester doesn't shows command whose name starts with get
The command is implemented but it is not shown by the ZigBee Tester interface Stefano Lenzi
05:36 pm Bug #131 (Rejected): Groups Cluster Command missing
The command is implemented but it is not shown by the ZigBee Tester interface Stefano Lenzi
05:21 pm Bug #133 (Feedback): Missing Parameters Group commands
GroupName to AddGroup has been added, but ViewGroup doesn't seem to have a GroupName paramter, am I right?
Please le...
Stefano Lenzi
05:19 pm Revision 532: Added parameter GroupName to the AddGroup command of the Groups cluster ( refs #133 )
Updated Scenes interface and implementaion in ZigBee Home Automation Driver to reflect the updated of ZigBee Cluster ... Stefano Lenzi
05:08 pm Bug #135 (Closed): Scenes cluster
Applied in changeset r531. Stefano Lenzi
05:07 pm Revision 531: Added missing groupId parameter to RemoveAllScenes command of the Scenes cluster ( ...
Stefano Lenzi
04:57 pm Bug #140 (Feedback): ZigBeeTester doesn't shows command whose name starts with get
Han I couldn't test, please let me know if command are displayed correctly or if you can see command that are related... Stefano Lenzi
04:55 pm Revision 530: CommandActionPanel does not display Command that starts with "get" even if are not ...
Stefano Lenzi
04:48 pm Bug #135 (In Progress): Scenes cluster
The GroupId parameter is still missing Stefano Lenzi
04:44 pm Bug #135 (Resolved): Scenes cluster
The typo has been resolved and the "Get Scene Membership" is implemented but it's not displayed by the ZigBeeTester, ... Stefano Lenzi
04:44 pm Bug #140 (Closed): ZigBeeTester doesn't shows command whose name starts with get
Some command even if implemented are not displayed from the ZigBeeTester interface Stefano Lenzi
04:23 pm Revision 529: Fixing typo removeAllScene should be removeAllScenes (refs #135)
Stefano Lenzi
03:37 pm Bug #139 (Feedback): Identify command
Han Alink wrote:
> I'm confused now; even a valid value now leads to an exception and shows the remark: No cluster s...
Stefano Lenzi
03:35 pm Revision 528: Fixes big issue introduced with r526: unable to set any numeric field to any value ...
Stefano Lenzi
03:02 pm Bug #139 (In Progress): Identify command
It not supposed to send an exception in case of a valid value, can post the exception log? ( I would advise you to at... Stefano Lenzi
02:40 pm Bug #134: addGroupIfIdentifying Command
Cannot test because it is not possible to set a device in Identify mode. see ticket #139 Han Alink
02:35 pm Bug #139: Identify command
I'm confused now; even a valid value now leads to an exception and shows the remark: No cluster sent on the, because ... Han Alink
01:39 pm Bug #134 (Resolved): addGroupIfIdentifying Command
Han: Would you mind to close the ticket if it works for you?
(P.S.: Account with *Users* have the right to close ti...
Stefano Lenzi
01:37 pm Bug #134 (Closed): addGroupIfIdentifying Command
Applied in changeset r527. Stefano Lenzi
01:37 pm Revision 527: Added a new ZigBeeSerializer that automatically increase the payload ( it may have ...
Fixed NPE with AddGroupIfIdentifyingCommand ( fixes #134 ) Stefano Lenzi
10:02 am Bug #139 (Feedback): Identify command
The exception is thrown as expected, it is not a issue on the code that create or send the command but on the parsing... Stefano Lenzi
09:49 am Revision 526: Better exception handling when issuing a command on the network ( refs #139 )
Stefano Lenzi
09:29 am Bug #136 (Closed): Exception thrwon when recieving UTIL_GET_DEVICE_INFO_RESPONSE
Fixed, as reported by the user on mailing-list (see "message":http://zb4osgi.aaloa.org/pipermail/dev/2012-October/000... Stefano Lenzi
09:28 am Bug #137 (Closed): PhysicalEnvironment Command
Stefano Lenzi
09:27 am Bug #138 (Closed): DeviceEnabled Command (Basic Cluster)
Stefano Lenzi
09:26 am Revision 525: Added support for boolean parameter
Throwing an exception when paramter is not supported Stefano Lenzi

10/18/2012

06:44 pm Bug #137: PhysicalEnvironment Command
Looks fine now!
I do not have the rights to close a ticket (I think).
Han Alink
06:33 pm Bug #138: DeviceEnabled Command (Basic Cluster)
looks fine now! Han Alink
05:37 pm Bug #137 (Feedback): PhysicalEnvironment Command
Please let me know if it works, and if it works please close the ticket Stefano Lenzi
05:36 pm Revision 524: Fixed typo of "PhysicalEnviroment" typo ( refs #137 )
Fixes issue in coverting Integer to Byte by means of Number interface ( refs #137 ) Stefano Lenzi
05:19 pm Bug #139: Identify command
java.lang.NumberFormatException: For input string: ""
at java.lang.NumberFormatException.forInputString(Unknown Sou...
Han Alink
05:15 pm Bug #138 (Feedback): DeviceEnabled Command (Basic Cluster)
It should be fixed give it a try Stefano Lenzi
05:14 pm Revision 523: Added support for Boolean data type ( refs #138 )
Stefano Lenzi
05:07 pm Bug #139: Identify command
Can you post the exception? Stefano Lenzi
05:05 pm Bug #139 (In Progress): Identify command
Stefano Lenzi
05:03 pm Bug #137 (In Progress): PhysicalEnvironment Command
Stefano Lenzi
05:01 pm Bug #138 (In Progress): DeviceEnabled Command (Basic Cluster)
Stefano Lenzi
04:52 pm Bug #139 (Closed): Identify command
The "Identify" Command (still) throws a nullpointer exception when the field is left empty. Han Alink
04:48 pm Bug #136 (Feedback): Exception thrwon when recieving UTIL_GET_DEVICE_INFO_RESPONSE
Stefano Lenzi
04:47 pm Bug #138 (Closed): DeviceEnabled Command (Basic Cluster)
When trying to set DeviceEnabled to false (by writing a 0), an exception is thrown:
Exception in thread "AWT-Event...
Han Alink
04:38 pm Bug #132 (Closed): Writing LocationDescription attributes fails
I'm happy that it works :)
I'm closing the ticket
Stefano Lenzi
04:38 pm Bug #137 (Closed): PhysicalEnvironment Command
Trying to write a number to "PhysicalEnviroment" leads to an exception: (also typo error; should read " PhysicalEnvir... Han Alink
04:34 pm Revision 522: Fixes parsing of UTIL_GET_DEVICE_INFO_RESPONSE ( refs 136 )
Stefano Lenzi
04:33 pm Bug #136 (Closed): Exception thrwon when recieving UTIL_GET_DEVICE_INFO_RESPONSE
As described by Del Rio Morales Antonio on mailing-list (see "original message":http://zb4osgi.aaloa.org/pipermail/de... Stefano Lenzi
04:32 pm Revision 521: folder hosting the initial contribution of Telecom Italia
Francesco Furfari
04:29 pm Bug #132: Writing LocationDescription attributes fails
It is possible to write the "location description" now. "garage" results in "garage". Han Alink
04:20 pm Bug #135 (Closed): Scenes cluster
The "Get scene membership" command is missing.
The "removeAllScene" command is missing the GroupID input parameter a...
Han Alink
04:17 pm Bug #132 (Feedback): Writing LocationDescription attributes fails
It should be working.
Han can you check if setting "garage" result in "garage" or "egarag" ?
Stefano Lenzi
04:12 pm Revision 520: Added support for Octet string, Long octet string, Long character string data types
Fixed serialization of Character string ( refs 132 )
Added test JUnit for WriteAttributeCommand that checks the getPa...
Stefano Lenzi
03:48 pm Bug #134 (Closed): addGroupIfIdentifying Command
Trying to issue a addGroupIfIdentifying Command (with both parameters set) leads to a nullpointer exception.
The l...
Han Alink
03:37 pm Bug #133 (Closed): Missing Parameters Group commands
The "AddGroup" and "ViewGroup" commands are missing the "GroupName" parameter in the tester interface.
See also "ad...
Han Alink
03:33 pm Bug #129 (Closed): Attributes of Basic Cluster
It is a differnt issue, I'll close this and we can continue to discuss on the new issue that I created #132 Stefano Lenzi
03:31 pm Bug #132 (Closed): Writing LocationDescription attributes fails
As reported by Han on the issue #129, trying to write the attribute result in _java.lang.ArrayIndexOutOfBoundsExcepti... Stefano Lenzi
03:30 pm Bug #131 (Rejected): Groups Cluster Command missing
The command "Get group membership" is missing. Han Alink
03:22 pm Bug #129: Attributes of Basic Cluster
You are right; I was looking at a read command which I issued before the Write command.
Nevertheless, the write acti...
Han Alink
01:55 pm Bug #129 (In Progress): Attributes of Basic Cluster
That's sound a bit odd, because the code for writing an attribute is generic code that is used for all the attributes... Stefano Lenzi
01:12 pm Bug #130: Basic Cluster typo error
I forgot to change the name that is displayed by the ZigBee Tester
(fixed with r519)
Stefano Lenzi
01:09 pm Revision 519: Fixed typo of DateCode attribute of Basic cluster ( fixes #129 )
Stefano Lenzi
12:34 pm Bug #130: Basic Cluster typo error
In tester browser the attribute still reads "DataCode". Han Alink
12:33 pm Bug #129: Attributes of Basic Cluster
Though it is possible to issue a write command, the frame that is sent is a read command.
The ZCL frame that is sent...
Han Alink
10:54 am Bug #128 (Closed): IdentifyTime attribute
Applied in changeset r518. Stefano Lenzi
10:30 am Revision 518: Report invalid value instead of NumberFormatException when setting a numeric attrib...
Default values for Subscribing are taken from the zigbee.zcl.library bundle Stefano Lenzi
10:14 am Bug #130 (Closed): Basic Cluster typo error
Applied in changeset r517. Stefano Lenzi
10:14 am Revision 517: Fixes typo in Basic attribute ( fixes #130 )
Stefano Lenzi
10:11 am Bug #129 (Closed): Attributes of Basic Cluster
Applied in changeset r516. Stefano Lenzi
10:11 am Revision 516: Set attributes as writeable ( fixes #129 )
Stefano Lenzi

10/17/2012

11:13 pm Bug #127 (In Progress): IdentifyQuery Command
The behavior described by you is correct (see Page 121 of ZigBee Cluster Library document version 075123r02ZB), but I... Stefano Lenzi
10:54 pm Bug #128 (In Progress): IdentifyTime attribute
The issue is a generic issue related to all the writeable attribute, but on the contrary of the Subscription issue (... Stefano Lenzi
10:48 pm Bug #129 (In Progress): Attributes of Basic Cluster
Accepted (see Page 103 of ZigBee Cluster Library document version 075123r02ZB) Stefano Lenzi
10:45 pm Bug #130 (In Progress): Basic Cluster typo error
Accepted (see Page 101 of ZigBee Cluster Library document version 075123r02ZB) Stefano Lenzi
07:06 pm Bug #130 (Closed): Basic Cluster typo error
Name of attribute should read DateCode instead of DataCode Han Alink
07:03 pm Bug #129 (Closed): Attributes of Basic Cluster
The following attributes of the Basic Cluster should be writable:
LocationDescription
PhysicalEnviroment
DeviceEna...
Han Alink
07:00 pm Bug #128 (Closed): IdentifyTime attribute
Writing to the IdentifyTime attribute fails when the input field is empty (number format exception). Han Alink
06:56 pm Bug #127 (Closed): IdentifyQuery Command
When an end device is not in identify mode, it will not respond to an IdentifyQuery command. However, the ZB4O softwa... Han Alink

10/16/2012

02:10 pm Revision 515: Better links
Stefano Lenzi
11:19 am Revision 514: update
Michele Girolami

10/15/2012

04:06 pm Revision 513
Filippo Palumbo
04:05 pm Revision 512
Filippo Palumbo
02:13 pm Improvement #125 (Closed): Handling "power off" device (removing it from devices list when not mo...
I think that the ticket #64 contains also this issue. Stefano Lenzi
02:05 pm Bug #126 (Closed): When leaving a field (Minimum or Maximum) empty, Java throws a “NumberFormatEx...
Applied in changeset r511. Stefano Lenzi
02:05 pm Bug #126 (Resolved): When leaving a field (Minimum or Maximum) empty, Java throws a “NumberFormat...
It has been fixed with r511 on the trunk, please give it a try and let us know Stefano Lenzi
12:52 pm Revision 511: Catching NumberFormatException and in case using default values for Minimum, Maximu...
Stefano Lenzi
11:42 am Bug #126 (Closed): When leaving a field (Minimum or Maximum) empty, Java throws a “NumberFormatEx...
ZigBee Tester throws a “NumberFormatException”, when subscribing to service with a blank value of either Minimum or M... Stefano Lenzi
10:48 am Revision 510: new partners
Michele Girolami
10:45 am Revision 509: new partners
Michele Girolami

10/11/2012

06:48 pm Revision 508: Private folder to import the goodday contribution
Francesco Furfari

10/08/2012

11:24 am Revision 507: trove4j bundle install
Manlio Bacco
11:19 am Revision 506: trove4j - bundle install
Manlio Bacco
« Previous
Next »
 

Also available in: Atom